RSS
当前位置 : 电脑维修 > 电脑维修 > 2811怎样配置默认路由

2811怎样配置默认路由

来源:未知 作者:老黑 时间:09-08-27 打印
CISCO2811怎么设置默认路由 路由器配置命令全集

命令状态
1. router>
路由器处于用户命令状态,这时用户可以看路由器的连接状态,访问其它网络和主机,但不能看到和更改路由器的设置内容。
2. router#
在router>提示符下键入enable,路由器进入特权命令状态router#,这时不但可以执行所有的用户命令,还可以看到和更改路由器的设置内容。
3. router(config)#
在router#提示符下键入configure terminal,出现提示符router(config)#,此时路由器处于全局设置状态,这时可以设置路由器的全局参数。
4. router(config-if)#; router(config-line)#; router(config-router)#;…
路由器处于局部设置状态,这时可以设置路由器某个局部的参数。
5. >
路由器处于RXBOOT状态,在开机后60秒内按ctrl-break可进入此状态,这时路由器不能完成正常的功能,只能进行软件升级和手工引导。
6. 设置对话状态
这是一台新路由器开机时自动进入的状态,在特权命令状态使用SETUP命令也可进入 fef 状态,这时可通过对话方式对路由器进行设置。

三、设置对话过程
1. 显示提示信息
2. 全局参数的设置
3. 接口参数的设置
4. 显示结果
利用设置对话过程可以避免手工输入命令的烦琐,但它还不能完全代替手工设置,一些特殊的设置还必须通过手工输入的方式完成。
进入设置对话过程后,路由器首先会显示一些提示信息:
--- System Configuration Dialog ---
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
这是告诉你在设置对话过程中的任何地方都可以键入“?”得到系统的帮助,按ctrl-c可以退出设置过程,缺省设置将显示在‘[]’中。然后路由器会问是否进入设置对话:
Would you like to enter the initial configuration dialog? [yes]:
如果按y或回车,路由器就会进入设置对话过程。首先你可以看到各端口当前的状况:
First, would you like to see the current interface summary? [yes]:
Any interface listed with OK? value "NO" does not have a valid configuration
Interface IP-Address OK? Method Status Protocol
Ethernet0 unassigned NO unset up up
Serial0 unassigned NO unset up up
……… ……… … …… … …
然后,路由器就开始全局参数的设置:
Configuring global parameters:
1.设置路由器名:
Enter host name [Router]:
2.设置进入特权状态的密文(secret),此密文在设置以后不会以明文方式显示:
The enable secret is a one-way cryptographic secret used
instead of the enable password when it exists.
Enter enable secret: cisco
3.设置进入特权状态的密码(password),此密码只在没有密文时起作用,并且在设置以后会以明文方式显示:
The enable password is used when there is no enable secret
and when using older software and some boot images.
Enter enable password: pass
4.设置虚拟终端访问时的密码:
Enter virtual terminal password: cisco
5.询问是否要设置路由器支持的各种网络协议:
Configure SNMP Network Management? [yes]:
Configure DECnet? [no]:
Configure AppleTalk? [no]:
Configure IPX? [no]:
Configure IP? [yes]:
Configure IGRP routing? [yes]:
Configure RIP routing? [no]:
………
6.如果配置的是拨号访问服务器,系统还会设置异步口的参数:
Configure Async lines? [yes]:
1) 设置线路的最高速度:
Async line speed [9600]:
2) 是否使用硬件流控:
Configure for HW flow control? [yes]:
3) 是否设置modem:
Configure for modems? [yes/no]: yes
4) 是否使用默认的modem命令:
Configure for default chat script? [yes]:
5) 是否设置异步口的PPP参数:
Configure for Dial-in IP SLIP/PPP access? [no]: yes
6) 是否使用动态IP地址:
Configure for Dynamic IP addresses? [yes]:
7) 是否使用缺省IP地址:
Configure Default IP addresses? [no]: yes
是否使用TCP头压缩:
Configure for TCP Header Compression? [yes]:
9) 是否在异步口上使用路由表更新:
Configure for routing updates on async links? [no]: y
10) 是否设置异步口上的其它协议。
接下来,系统会对每个接口进行参数的设置。
1.Configuring interface Ethernet0:
1) 是否使用此接口:
Is this interface in use? [yes]:
2) 是否设置此接口的IP参数:
Configure IP on this interface? [yes]:
3) 设置接口的IP地址:
IP address for this interface: 192.168.162.2
4) 设置接口的IP子网掩码:
Number of bits in subnet field [0]:
Class C network is 192.168.162.0, 0 subnet bits; mask is /24
在设置完所有接口的参数后,系统会把整个设置对话过程的结果显示出 fef :
The following configuration command script was created:
hostname Router
enable secret 5 $1$W5Oh$p6J7tIgRMBOIKVXVG53Uh1
enable password pass
…………
请注意在enable secret后面显示的是乱码,而enable password后面显示的是设置的内容。
显示结束后,系统会问是否使用这个设置:
Use this configuration? [yes/no]: yes
如果回答yes,系统就会把设置的结果存入路由器的NVRAM中,然后结束设置对话过程,使路由器开始正常的工作。
返回目录
 

四、常用命令
1. 帮助
在IOS操作中,无论任何状态和位置,都可以键入“?”得到系统的帮助。
2. 改变命令状态
任务 命令
进入特权命令状态 enable
退出特权命令状态 disable
进入设置对话状态 setup
进入全局设置状态 config terminal
退出全局设置状态 end
进入端口设置状态 interface type slot/number
进入子端口设置状态 interface type number.subinterface [point-to-point | multipoint]
进入线路设置状态 line type slot/number
进入路由设置状态 router protocol
退出局部设置状态 exit
3. 显示命令
任务 命令
查看版本及引导信息 show version
查看运行设置 show running-config
查看开机设置 show startup-config
显示端口信息 show interface type slot/number
显示路由信息 show ip router
4. 拷贝命令
用于IOS及CONFIG的备份和升级

5. 网络命令
任务 命令
登录远程主机 telnet hostname|IP address
网络侦测 ping hostname|IP address
路由跟踪 trace hostname|IP address
 
6. 基本设置命令
任务 命令
全局设置 config terminal
设置访问用户及密码 username username password password
设置特权密码 enable secret password
设置路由器名 hostname name
设置静态路由 ip route destination subnet-mask next-hop
启动IP路由 ip routing
启动IPX路由 ipx routing
端口设置 interface type slot/number
设置IP地址 ip address address subnet-mask
设置IPX网络 ipx network network
激活端口 no shutdown
物理线路设置 line type number
启动登录进程 login [local|tacacs server]
设置登录密码 password password
 

五、配置IP寻址
 
1. IP地址分类
IP地址分为网络地址和主机地址二个部分,A类地址前8位为网络地址,后24位为主机地址,B类地址16位为网络地址,后16位为主机地址,C类地址前24位为网络地址,后8位为主机地址,网络地址范围如下表所示:
种类 网络地址范围
A  1.0.0.0 到126.0.0.0有效 0.0.0.0 和127.0.0.0保留
B 128.1.0.0到191.254.0.0有效 128.0.0.0和191.255.0.0保留
C 192.0.1.0 到223.255.254.0有效 192.0.0.0和223.255.255.0保留
D 224.0.0.0到239.255.255.255用于多点广播
E 240.0.0.0到255.255.255.254保留 255.255.255.255用于广播
2. 分配接口IP地址
任务 命令
接口设置 interface type slot/number
为接口设置IP地址 ip address ip-address mask
掩玛(mask)用于识别IP地址中的网络地址位数,IP地址(ip-address)和掩码(mask)相与即得到网络地址。
3. 使用可变长的子网掩码
通过使用可变长的子网掩码可以让位于不同接口的同一网络编号的网络使用不同的掩码,这样可以节省IP地址,充分利用有效的IP地址空间。
如下图所示:
Router1和Router2的E0端口均使用了C类地址192.1.0.0作为网络地址,Router1的E0的网络地址为192.1.0.128,掩码为255.255.255.192, Router2的E0的网络地址为192.1.0.64,掩码为255.255.255.192,这样就将一个C类网络地址分配给了二个网,既划分了二个子网,起到了节约地址的作用。
4. 使用网络地址翻译(NAT)
NAT(Network Address Translation)起到将 fef 部私有地址翻译成外部合法的全局地址的功能,它使得不具有合法IP地址的用户可以通过NAT访问到外部Internet.
当建立内部网的时候,建议使用以下地址组用于主机,这些地址是由Network Working Group(RFC 1918)保留用于私有网络地址分配的.
l Class A:10.1.1.1 to 10.254.254.254
l Class B:172.16.1.1 to 172.31.254.254
l Class C:192.168.1.1 to 192.168.254.254
命令描述如下:
任务 命令
定义一个标准访问列表 access-list access-list-number permit source [source-wildcard]
定义一个全局地址池 ip nat pool name start-ip end-ip {netmask netmask | prefix-length prefix-length} [type rotary]
建立动态地址翻译 ip nat inside source {list {access-list-number | name} pool name [overload] | static local-ip global-ip}
指定内部和外部端口 ip nat {inside | outside}
如下图所示,

路由器的Ethernet 0端口为inside端口,即此端口连接内部网络,并且此端口所连接的网络应该被翻译,Serial 0端口为outside端口,其拥有合法IP地址(由NIC或服务提供商所分配的合法的IP地址),来自网络10.1.1.0/24的主机将从IP地址池c2501中选择一个地址作为自己的合法地址,经由Serial 0口访问Internet。命令ip nat inside source list 2 pool c2501 overload中的参数overload,将允许多个内部地址使用相同的全局地址(一个合法IP地址,它是由NIC或服务提供商所分配的地址)。命令ip nat pool c2501 202.96.38.1 202.96.38.62 netmask 255.255.255.192定义了全局地址的范围。
设置如下:
ip nat pool c2501 202.96.38.1 202.96.38.62 netmask 255.255.255.192
interface Ethernet 0
ip address 10.1.1.1 255.255.255.0
ip nat inside
!
interface Serial 0
ip address 202.200.10.5 255.255.255.252
ip nat outside
!
ip route 0.0.0.0 0.0.0.0 Serial 0
access-list 2 permit 10.0.0.0 0.0.0.255
! Dynamic NAT
!
ip nat inside source list 2 pool c2501 overload
line console 0
exec-timeout 0 0
!
line vty 0 4
end
 
六、配置静态路由
通过配置静态路由,用户可以人为地指定对某一网络访问时所要经过的路径,在网络结构比较简单,且一般到达某一网络所经过的路径唯一的情况下采用静态路由。
任务 命令
建立静态路由 ip route prefix mask {address | interface} [distance] [tag tag] [permanent]
Prefix :所要到达的目的网络
mask :子网掩码
address :下一个跳的IP地址,即相邻路由器的端口地址。
interface :本地网络接口
distance :管理距离(可选)
tag tag :tag值(可选)
permanent :指定此路由即使该端口关掉也不被移掉。

以下在Router1上设置了访问192.1.0.64/26这个网下一跳地址为192.200.10.6,即当有目的地址属于192.1.0.64/26的网络范围的数据报,应将其路由到地址为192.200.10.6的相邻路由器。在Router3上设置了访问192.1.0.128/26及192.200.10.4/30这二个网下一跳地址为192.1.0.65。由于在Router1上端口Serial 0地址为192.200.10.5,192.200.10.4/30这个网属于直连的网,已经存在访问192.200.10.4/30的路径,所以不需要在Router1上添加静态路由。
Router1:
ip route 192.1.0.64 255.255.255.192 192.200.10.6
Router3:
ip route 192.1.0.128 255.255.255.192 192.1.0.65
ip route 192.200.10.4 255.255.255.252 192.1.0.65
同时由于路由器Router3除了与路由器Router2相连外,不再与其他路由器相连,所以也可以为它赋予一条默认路由以代替以上的二条静态路由,
ip route 0.0.0.0 0.0.0.0 192.1.0.65
即只要没有在路由表里找到去特定目的地址的路径 fef ,则数据均被路由到地址为192.1.0.65的相邻路由器。
返回目录 路由器配置命令全集

命令状态
1. ROUTER>
路由器处于用户命令状态,这时用户可以看路由器的连接状态,访问其它网络和主机,但不能看到和更改路由器的设置内容。
2. ROUTER#
在ROUTER>提示符下键入ENABLE,路由器进入特权命令状态ROUTER#,这时不但可以执行所有的用户命令,还可以看到和更改路由器的设置内容。
3. ROUTER(CONFIG)#
在ROUTER#提示符下键入CONFIGURE TERMINAL,出现提示符ROUTER(CONFIG)#,此时路由器处于全局设置状态,这时可以设置路由器的全局参数。
4. ROUTER(CONFIG-IF)#; ROUTER(CONFIG-LINE)#; ROUTER(CONFIG-ROUTER)#;…
路由器处于局部设置状态,这时可以设置路由器某个局部的参数。
5. >
路由器处于RXBOOT状态,在开机后60秒内按CTRL-BREAK可进入此状态,这时路由器不能完成正常的功能,只能进行软件升级和手工引导。
6. 设置对话状态
这是一台新路由器开机时自动进入的状态,在特权命令状态使用SETUP命令也可进入此状态,这时可通过对话方式对路由器进行设置。

三、设置对话过程
1. 显示提示信息
2. 全局参数的设置
3. 接口参数的设置
4. 显示结果
利用设置对话过程可以避免手工输入命令的烦琐,但它还不能完全代替手工设置,一些特殊的设置还必须通过手工输入的方式完成。
进入设置对话过程后,路由器首先会显示一些提示信息:
--- SYSTEM CONFIGURATION DIALOG ---
AT ANY POINT YOU MAY ENTER A QUESTION MARK '?' FOR HELP.
USE CTRL-C TO ABORT CONFIGURATION DIALOG AT ANY PROMPT.
DEFAULT SETTINGS ARE IN SQUARE BRACKETS '[]'.
这是告诉你在设置对话过程中的任何地方都可以键入“?”得到系统的帮助,按CTRL-C可以退出设置过程,缺省设置将显示在‘[]’中。然后路由器会问是否进入设置对话:
WOULD YOU LIKE TO ENTER THE INITIAL CONFIGURATION DIALOG? [YES]:
如果按Y或回车,路由器就会进入设置对话过程。首先你可以看到各端口当前的状况:
FIRST, WOULD YOU LIKE TO SEE THE CURRENT INTERFACE SUMMARY? [YES]:
ANY INTERFACE LISTED WITH OK? fef VALUE "NO" DOES NOT HAVE A VALID CONFIGURATION
INTERFACE IP-ADDRESS OK? METHOD STATUS PROTOCOL
ETHERNET0 UNASSIGNED NO UNSET UP UP
SERIAL0 UNASSIGNED NO UNSET UP UP
……… ……… … …… … …
然后,路由器就开始全局参数的设置:
CONFIGURING GLOBAL PARAMETERS:
1.设置路由器名:
ENTER HOST NAME [ROUTER]:
2.设置进入特权状态的密文(SECRET),此密文在设置以后不会以明文方式显示:
THE ENABLE SECRET IS A ONE-WAY CRYPTOGRAPHIC SECRET USED
INSTEAD OF THE ENABLE PASSWORD WHEN IT EXISTS.
ENTER ENABLE SECRET: CISCO
3.设置进入特权状态的密码(PASSWORD),此密码只在没有密文时起作用,并且在设置以后会以明文方式显示:
THE ENABLE PASSWORD IS USED WHEN THERE IS NO ENABLE SECRET
AND WHEN USING OLDER SOFTWARE AND SOME BOOT IMAGES.
ENTER ENABLE PASSWORD: PASS
4.设置虚拟终端访问时的密码:
ENTER VIRTUAL TERMINAL PASSWORD: CISCO
5.询问是否要设置路由器支持的各种网络协议:
CONFIGURE SNMP NETWORK MANAGEMENT? [YES]:
CONFIGURE DECNET? [NO]:
CONFIGURE APPLETALK? [NO]:
CONFIGURE IPX? [NO]:
CONFIGURE IP? [YES]:
CONFIGURE IGRP ROUTING? [YES]:
CONFIGURE RIP ROUTING? [NO]:
………
6.如果配置的是拨号访问服务器,系统还会设置异步口的参数:
CONFIGURE ASYNC LINES? [YES]:
1) 设置线路的最高速度:
ASYNC LINE SPEED [9600]:
2) 是否使用硬件流控:
CONFIGURE FOR HW FLOW CONTROL? [YES]:
3) 是否设置MODEM:
CONFIGURE FOR MODEMS? [YES/NO]: YES
4) 是否使用默认的MODEM命令:
CONFIGURE FOR DEFAULT CHAT SCRIPT? [YES]:
5) 是否设置异步口的PPP参数:
CONFIGURE FOR DIAL-IN IP SLIP/PPP ACCESS? [NO]: YES
6) 是否使用动态IP地址:
CONFIGURE FOR DYNAMIC IP ADDRESSES? [YES]:
7) 是否使用缺省IP地址:
CONFIGURE DEFAULT IP ADDRESSES? [NO]: YES
是否使用TCP头压缩:
CONFIGURE FOR TCP HEADER COMPRESSION? [YES]:
9) 是否在异步口上使用路由表更新:
CONFIGURE FOR ROUTING UPDATES ON ASYNC LINKS? [NO]: Y
10) 是否设置异步口上的其它协议。
接下来,系统会对每个接口进行参数的设置。
1.CONFIGURING INTERFACE ETHERNET0:
1) 是否使用此接口:
IS THIS INTERFACE IN USE? [YES]:
2) 是否设置此接口的IP参数:
CONFIGURE IP ON THIS INTERFACE? [YES]:
3) 设置接口的IP地址:
IP ADDRESS FOR THIS INTERFACE: 192.168.162.2
4) 设置接口的IP子网掩码:
NUMBER OF BITS IN SUBNET FIELD [0]:
CLASS C NETWORK IS 192.168.162.0, 0 SUBNET BITS; MASK IS /24
在设置完所有接口的参数后,系统会把整个设置对话过程的结果显示出来:
THE FOLLOWING CONFIGURATION COMMAND SCRIPT WAS CREATED:
HOSTNAME ROUTER
ENABLE SECRET 5 $1$W5OH$P6J7TIGRMBOIKVXVG53UH1
ENABLE PASSWORD PASS
…………
请注意在ENABLE SECRET后面显示的是乱码,而ENABLE PASSWORD后面显示的是设置的内容。
显示结束后,系统会问是否使用这个设置:
USE THIS CONFIGURATION? [YES/NO]: YES
如果回答YES,系统就会把设置的结果存入路由器的NVRAM中,然后结束设置对话过程,使路由器开始正常的工作。
返回目录
 

四、常用命令
1. 帮助
在IOS操作中,无论任何状态和位置,都可以键入“?”得到系统的帮助。
2. 改变命令状态
任务 命令
进入特权命令状态 ENABLE
退出特权命令状态 DISABLE
进入设置对话状态 SETUP
进入全局设置状态 CONFIG TERMINAL
退出全局设置状态 END
进入端口设置状态 INTERFACE TYPE SLOT/NUMBER
进入子端口设置状态 INTERFACE TYPE NUMBER.SUBINTERFACE [POINT-TO-POINT | MULTIPOINT]
进入线路设置状态 LINE TYPE SLOT/NUMBER
进入路由设置状态 ROUTER PROTOCOL
退出局部设置状 fef EXIT
3. 显示命令
任务 命令
查看版本及引导信息 SHOW VERSION
查看运行设置 SHOW RUNNING-CONFIG
查看开机设置 SHOW STARTUP-CONFIG
显示端口信息 SHOW INTERFACE TYPE SLOT/NUMBER
显示路由信息 SHOW IP ROUTER
4. 拷贝命令
用于IOS及CONFIG的备份和升级

5. 网络命令
任务 命令
登录远程主机 TELNET HOSTNAME|IP ADDRESS
网络侦测 PING HOSTNAME|IP ADDRESS
路由跟踪 TRACE HOSTNAME|IP ADDRESS
 
6. 基本设置命令
任务 命令
全局设置 CONFIG TERMINAL
设置访问用户及密码 USERNAME USERNAME PASSWORD PASSWORD
设置特权密码 ENABLE SECRET PASSWORD
设置路由器名 HOSTNAME NAME
设置静态路由 IP ROUTE DESTINATION SUBNET-MASK NEXT-HOP
启动IP路由 IP ROUTING
启动IPX路由 IPX ROUTING
端口设置 INTERFACE TYPE SLOT/NUMBER
设置IP地址 IP ADDRESS ADDRESS SUBNET-MASK
设置IPX网络 IPX NETWORK NETWORK
激活端口 NO SHUTDOWN
物理线路设置 LINE TYPE NUMBER
启动登录进程 LOGIN [LOCAL|TACACS SERVER]
设置登录密码 PASSWORD PASSWORD
 

五、配置IP寻址
 
1. IP地址分类
IP地址分为网络地址和主机地址二个部分,A类地址前8位为网络地址,后24位为主机地址,B类地址16位为网络地址,后16位为主机地址,C类地址前24位为网络地址,后8位为主机地址,网络地址范围如下表所示:
种类 网络地址范围
A  1.0.0.0 到126.0.0.0有效 0.0.0.0 和127.0.0.0保留
B 128.1.0.0到191.254.0.0有效 128.0.0.0和191.255.0.0保留
C 192.0.1.0 到223.255.254.0有效 192.0.0.0和223.255.255.0保留
D 224.0.0.0到239.255.255.255用于多点广播
E 240.0.0.0到255.255.255.254保留 255.255.255.255用于广播
2. 分配接口IP地址
任务 命令
接口设置 INTERFACE TYPE SLOT/NUMBER
为接口设置IP地址 IP ADDRESS IP-ADDRESS MASK
掩玛(MASK)用于识别IP地址中的网络地址位数,IP地址(IP-ADDRESS)和掩码(MASK)相与即得到网络地址。
3. 使用可变长的子网掩码
通过使用可变长的子网掩码可以让位于不同接口的同一网络编号的网络使用不同的掩码,这样可以节省IP地址,充分利用有效的IP地址空间。
如下图所示:
ROUTER1和ROUTER2的E0端口均使用了C类地址192.1.0.0作为网络地址,ROUTER1的E0的网络地址为192.1.0.128,掩码为255.255.255.192, ROUTER2的E0的网络地址为192.1.0.64,掩码为255.255.255.192,这样就将一个C类网络地址分配给了二个网,既划分了二个子网,起到了节约地址的作用。
4. 使用网络地址翻译(NAT)
NAT(NETWORK ADDRESS TRANSLATION)起到将内部私有地址翻译成外部合法的全局地址的功能,它使得不具有合法IP地址的用户可以通过NAT访问到外部INTERNET.
当建立内部网的时候,建议使用以下地址组用于主机,这些地址是由NETWORK WORKING GROUP(RFC 1918)保留用于私有网络地址分配的.
L CLASS A:10.1.1.1 TO 10.254.254.254
L CLASS B:172.16.1.1 TO 172.31.254.254
L CLASS C:192.168.1.1 TO 192.168.254.254
命令描述如下:
任务 命令
定义一个标准访问列表 ACCESS-LIST ACCESS-LIST-NUMBER PERMIT SOURCE [SOURCE-WILDCARD]
定义一个全局地址池 IP NAT POOL NAME START-IP END-IP {NETMASK NETMASK | PREFIX-LENGTH PREFIX-LENGTH} [TYPE ROTARY]
建立动态地址翻译 IP NAT INSIDE SOURCE {LIST {ACCESS-LIST-NUMBER | NAME} POOL NAME [OVERLOAD] | STATIC LOCAL-IP GLOBAL-IP}
指定内部和外部端口 IP NAT {INSIDE | OUTSIDE}
如下图所示,

路由器的ETHERNET 0端口为INSIDE端口,即此端口连接内部网络,并且此端口所连接的网络应该被翻译,SERIAL 0端口为OUTSIDE端口,其拥有合法IP地址(由NIC或服务提供商所分配的合法的IP地址),来自网络10.1.1.0 fef /24的主机将从IP地址池C2501中选择一个地址作为自己的合法地址,经由SERIAL 0口访问INTERNET。命令IP NAT INSIDE SOURCE LIST 2 POOL C2501 OVERLOAD中的参数OVERLOAD,将允许多个内部地址使用相同的全局地址(一个合法IP地址,它是由NIC或服务提供商所分配的地址)。命令IP NAT POOL C2501 202.96.38.1 202.96.38.62 NETMASK 255.255.255.192定义了全局地址的范围。
设置如下:
IP NAT POOL C2501 202.96.38.1 202.96.38.62 NETMASK 255.255.255.192
INTERFACE ETHERNET 0
IP ADDRESS 10.1.1.1 255.255.255.0
IP NAT INSIDE
!
INTERFACE SERIAL 0
IP ADDRESS 202.200.10.5 255.255.255.252
IP NAT OUTSIDE
!
IP ROUTE 0.0.0.0 0.0.0.0 SERIAL 0
ACCESS-LIST 2 PERMIT 10.0.0.0 0.0.0.255
! DYNAMIC NAT
!
IP NAT INSIDE SOURCE LIST 2 POOL C2501 OVERLOAD
LINE CONSOLE 0
EXEC-TIMEOUT 0 0
!
LINE VTY 0 4
END
 
六、配置静态路由
通过配置静态路由,用户可以人为地指定对某一网络访问时所要经过的路径,在网络结构比较简单,且一般到达某一网络所经过的路径唯一的情况下采用静态路由。
任务 命令
建立静态路由 IP ROUTE PREFIX MASK {ADDRESS | INTERFACE} [DISTANCE] [TAG TAG] [PERMANENT]
PREFIX :所要到达的目的网络
MASK :子网掩码
ADDRESS :下一个跳的IP地址,即相邻路由器的端口地址。
INTERFACE :本地网络接口
DISTANCE :管理距离(可选)
TAG TAG :TAG值(可选)
PERMANENT :指定此路由即使该端口关掉也不被移掉。

以下在ROUTER1上设置了访问192.1.0.64/26这个网下一跳地址为192.200.10.6,即当有目的地址属于192.1.0.64/26的网络范围的数据报,应将其路由到地址为192.200.10.6的相邻路由器。在ROUTER3上设置了访问192.1.0.128/26及192.200.10.4/30这二个网下一跳地址为192.1.0.65。由于在ROUTER1上端口SERIAL 0地址为192.200.10.5,192.200.10.4/30这个网属于直连的网,已经存在访问192.200.10.4/30的路径,所以不需要在ROUTER1上添加静态路由。
ROUTER1:
IP ROUTE 192.1.0.64 255.255.255.192 192.200.10.6
ROUTER3:
IP ROUTE 192.1.0.128 255.255.255.192 192.1.0.65
IP ROUTE 192.200.10.4 255.255.255.252 192.1.0.65
同时由于路由器ROUTER3除了与路由器ROUTER2相连外,不再与其他路由器相连,所以也可以为它赋予一条默认路由以代替以上的二条静态路由,
IP ROUTE 0.0.0.0 0.0.0.0 192.1.0.65
即只要没有在路由表里找到去特定目的地址的路径,则数据均被路由到地址为192.1.0.65的相邻路由器。
返回目录     Access-enable  允许路由器在动态访问列表中创建临时访问列表入口
  Access-group  把访问控制列表(ACL)应用到接口上
  Access-list  定义一个标准的IP ACL
  Access-template  在连接的路由器上手动替换临时访问列表入口

  Appn  向APPN子系统发送命令
  Atmsig   执行ATM信令命令
  B   手动引导操作系统
  Bandwidth   设置接口的带宽
  Banner motd   指定日期信息标语
  Bfe   设置突发事件手册模式
  Boot system   指定路由器启动时加载的系统映像
  Calendar   设置硬件日历
  Cd   更改路径
  Cdp enable   允许接口运行CDP协议
  Clear   复位功能
  Clear counters   清除接口计数器
  Clear interface   重新启动接口上的件逻辑
  Clockrate   设置串口硬件连接的时钟速率,如网络接口模块和接口处理器能接受的速率
  Cmt   开启/关闭FDDI连接管理功能
  Config-register   修改配置寄存器设置
  Configure   允许进入存在的配置模式,在中心站点上维护并保存配置信息
  Configure memory   从NVRAM加载配置信息
  Configure terminal   从终端进行手动配置
  Connect   打开一个终端连接
  Copy   复制配置或映像数据
  Copy flash tftp   备份系统映像文件到TFTP服务器
  Copy running-config startup-config   将RAM中的当前配置存储到NVRAM
  Copy running-config tftp   将RAM中的当前配置存储到网络TFTP服务器上
  Copy tftp flash   从TFTP服务器上下载新映像到Flash
  Copy tftp running-config   从TFTP服务器上下载配置文件
  Debug   使用调试功能
  Debug dialer   显示接口在拨什么号及诸如此类的信息
  Debug ip rip   显示RIP路由选择更新数据
  Debug ipx routing activity   显示关于路由选择协议(RIP)更新数据包的信息
  Debug ipx sap   显示关于SAP(业务通告协议)更新数据包信息
  Debug isdn q921   显示在路由器D通道ISDN接口上发生的数据链路层(第2层)的访问过程
  Debug ppp   显示在实施PPP中发生的业务和交换信息
  Delete   删除文件
  Deny   为一个已命名的IP ACL设置条件
  Dialer idle-timeout   规定线路断开前的空闲时间的长度
  Dialer map   设置一个串行接口来呼叫一个或多个地点
  Dialer wait-for-carrier-time   规定花多长时间等待一个载体
  Dialer-group   通过对属于一个特定拨号组的接口进行配置来访问控制
  Dialer-list protocol   定义一个数字数据接受器(DDR)拨号表以通过协议或ACL与协议的组合来控制控制拨号
  Dir   显示给定设备上的文件
  Disable   关闭特许模式
  Disconnect   断开已建立的连接
  Enable   打开特许模式
  Enable password   确定一个密码 fef 以防止对路由器非授权的访问

Enable password   设置本地口令控制不同特权级别的访问
  Enable secret   为enable password命令定义额外一层安全性 (强制安全,密码非明文显示)
  Encapsulation frame-relay   启动帧中继封装


  Encapsulation novell-ether   规定在网络段上使用的Novell独一无二的格式
  Encapsulation PPP   把PPP设置为由串口或ISDN接口使用的封装方法
  Encapsulation sap   规定在网络段上使用的以太网802.2格式Cisco的密码是sap
  End   退出配置模式
  Erase   删除闪存或配置缓存
  Erase startup-config   删除NVRAM中的内容
  Exec-timeout   配置EXEC命令解释器在检测到用户输入前所等待的时间
  Exit   退出所有配置模式或者关闭一个激活的终端会话和终止一个EXEC
  Exit   终止任何配置模式或关闭一个活动的对话和结束EXEC
  format   格式化设备
  Frame-relay local-dlci   为使用帧中继封装的串行线路启动本地管理接口(LMI)
  Help   获得交互式帮助系统
  History   查看历史记录
  Hostname   使用一个主机名来配置路由器,该主机名以提示符或者缺省文件名的方式使用
  Interface   设置接口类型并且输入接口配置模式
  Interface   配置接口类型和进入接口配置模式
  Interface serial   选择接口并且输入接口配置模式
  Ip access-group   控制对一个接口的访问
  Ip address   设定接口的网络逻辑地址
  Ip address   设置一个接口地址和子网掩码并开始IP处理
  Ip default-network   建立一条缺省路由
  Ip domain-lookup   允许路由器缺省使用DNS
  Ip host   定义静态主机名到IP地址映射
  Ip name-server   指定至多6个进行名字-地址解析的服务器地址
  Ip route   建立一条静态路由
  Ip unnumbered   在为给一个接口分配一个明确的IP地址情况下,在串口上启动互联网协议(IP)的处理过程
  Ipx delay   设置点计数
  Ipx ipxwan   在串口上启动IPXWAN协议
  Ipx maximum-paths   当转发数据包时设置Cisco IOS软件使用的等价路径数量
  Ipx network   在一个特定接口上启动互联网数据包交换(IPX)的路由选择并且选择封装的类型(用帧封装)
  Ipx router   规定使用的路由选择协议
  Ipx routing   启动IPX路由选择
  Ipx sap-interval   在较慢的链路上设置较不频繁的SAP(业务广告协议)更新
  Ipx type-20-input-checks   限制对IPX20类数据包广播的传播的接受
  Isdn spid1   在路由器上规定已经由ISDN业务供应商为B1信道分配的业务简介号(SPID)
  Isdn spid2   在路由器上规定已经由ISDN业务供应商为B2信道分配的业务简介号(SPID)
  Isdntch-type   规定了在ISDN接口上的中央办公区的交换机的类型
  Keeplive   为使用帧中继封装的串行线路LMI(本地管理接口)机制
  Lat   打开LAT连接
  Line   确定一个特定的线路和开始线路配置
  Line concole   设置控制台端口线路
  Line vty   为远程控制台访问规定了一个虚拟终端
  Lock   锁住终端控制台
  Login   在终端会话登录过程中启动了密码检查
  Login   以某用户身份登录,登录时允许口令验证
Logout   退出EXEC模式
  Mbranch   向下跟踪组播地址路由至终端
  fef Media-type   定义介质类型
  Metric holddown   把新的IGRP路由选择信息与正在使用的IGRP路由选择信息隔离一段时间
  Mrbranch   向上解析组播地址路由至枝端
  Mrinfo   从组播路由器上获取邻居和版本信息
  Mstat   对组播地址多次路由跟踪后显示统计数字
  Mtrace   由源向目标跟踪解析组播地址路径
  Name-connection   命名已存在的网络连接
  Ncia   开启/关闭NCIA服务器
  Network   把一个基于NIC的地址分配给一个与它直接相连的路由器把网络与一个IGRP的路由选择的过程联系起来在IPX路由器配置模式下,在网络上启动加强的IGRP
  Network   指定一个和路由器直接相连的网络地址段
  Network-number   对一个直接连接的网络进行规定
  No shutdown   打开一个关闭的接口
  Pad   开启一个X.29 PAD连接
  Permit   为一个已命名的IP ACL设置条件
  Ping   把ICMP响应请求的数据包发送网络上的另一个节点检查主机的可达性和网络的连通性对网络的基本连通性进行诊断
  Ping   发送回声请求,诊断基本的网络连通性
  Ppp   开始IETF点到点协议
  Ppp   authentication 启动Challenge握手鉴权协议(CHAP)或者密码验证协议(PAP)或者将两者都启动,并且对在接口上选择的CHAP和PAP验证的顺序进行规定
  Ppp chap hostname   当用CHAP进行身份验证时,创建一批好像是同一台主机的拨号路由器
  Ppp chap password   设置一个密码,该密码被发送到对路由器进行身份验证的主机命令对进入路由器的用户名/密码的数量进行了限制
  Ppp pap sent-username   对一个接口启动远程PAP支持,并且在PAP对同等层请求数据包验证过程中使用sent-username和password
  Protocol   对一个IP路由选择协议进行定义,该协议可以是RIP,内部网关路由选择协议(IGRP),开放最短路径优先(OSPF),还可以是加强的IGRP
  Pwd   显示当前设备名

Reload   关闭并执行冷启动;重启操作系统
  Rlogin   打开一个活动的网络连接
  Router   由第一项定义的IP路由协议作为路由进程,例如:router rip 选择RIP作为路由协议
  Router igrp   启动一个IGRP的路由选择过程


  Router rip   选择RIP作为路由选择协议
  Rsh   执行一个远程命令
  Sdlc   发送SDLC测试帧
  Send   在tty线路上发送消息
  Service password-encryption   对口令进行加密
  Setup   运行Setup命令
  Show   显示运行系统信息
  Show access-lists   显示当前所有ACL的内容
  Show buffers   显示缓存器统计信息
  Show cdp entry   显示CDP表中所列相邻设备的信息
  Show cdp interface   显示打开的CDP接口信息
  Show cdp neighbors   显示CDP查找进程的结果
  Show dialer   显示为DDR(数字数据接受器)设置的串行接口的一般诊断信息
  Show flash   显示闪存的布局和内容信息
  Show frame-relay lmi   显示关于本地管理接口(LMI)的统计信息
  Show frame-relay map   显示关于连接的当前映射入口和信息
  Show frame-relay pvc   显示关于帧中继接口的永久虚电路(pvc)的统计信息
  Show hosts   显示主机名和地址的缓存列表
Show interfaces   显示设置在路由器和访问服务器上所有接口的统计信息
  Show interfaces   显示路由器上配置的所有接 fef 口的状态
  Show interfaces serial   显示关于一个串口的信息
  Show ip interface   列出一个接口的IP信息和状态的小结
  Show ip interface   列出接口的状态和全局参数
  Show ip protocols   显示活动路由协议进程的参数和当前状态
  Show ip route   显示路由选择表的当前状态
  Show ip router   显示IP路由表信息
  Show ipx interface   显示Cisco IOS软件设置的IPX接口的状态以及每个接口中的参数
  Show ipx route   显示IPX路由选择表的内容
  Show ipx servers   显示IPX服务器列表
  Show ipx traffic   显示数据包的数量和类型
  Show isdn active   显示当前呼叫的信息,包括被叫号码、建立连接前所花费的时间、在呼叫期间使用的自动化操作控制(AOC)收费单元以及是否在呼叫期间和呼叫结束时提供AOC信息
  Show isdn ststus   显示所有isdn接口的状态、或者一个特定的数字信号链路(DSL)的状态或者一个特定isdn接口的状态
  Show memory   显示路由器内存的大小,包括空闲内存的大小
  Show processes   显示路由器的进程
  Show protocols   显示设置的协议
  Show protocols   显示配置的协议。这条命令显示任何配置了的第3层协议的状态
  Show running-config   显示RAM中的当前配置信息
  Show spantree   显示关于虚拟局域网(VLAN)的生成树信息
  Show stacks   监控和中断程序对堆栈的使用,并显示系统上一次重启的原因
  Show startup-config   显示NVRAM中的启动配置文件
  Show ststus   显示ISDN线路和两个B信道的当前状态
  Show version   显示系统硬件的配置,软件的版本,配置文件的名称和来源及引导映像
  Shutdown   关闭一个接口
  Telnet   开启一个telect连接
  Term ip   指定当前会话的网络掩码的格式
  Term ip netmask-format   规定了在show命令输出中网络掩码显示的格式
  Timers basic   控制着IGRP以多少时间间隔发送更新信息
  Trace   跟踪IP路由
  Username password   规定了在CHAP和PAP呼叫者身份验证过程中使用的密码
  Verify   检验flash文件
  Where   显示活动连接
  Which-route   OSI路由表查找和显示结果
  Write   运行的配置信息写入内存,网络或终端
  Write erase   现在由copy startup-config命令替换
  X3   在PAD上设置X.3参数
  Xremote   进入XRemote模式   我来要你的分数

超级终端进入
sys
进入配置模式,如果此路由在配置前以前有过配置,那么在进入sys前打命令delete config.cfg删除,之后重启路由
若以前没有配置过,按下步执行

选择一个lan口做公网出口,另一个lan口做子网
命令如下
int eth0/0
ip address 192.168.138.219 255.255.255.248
q(退出)

int eth0/1
ip address 192.168.1.1 255.255.255.0
q

ip route-static 0.0.0.0 0.0.0.0 192.168.138.217

acl number 2001
rule 0 permit source 192.168.1.0 0.0.0.255
rule deny
q

nat address-group 1 192.168.138.219 192.168.138.219

int eth0/0
nat outbound 2001 address-group 1

save

q

reboot重启路由,DNS在你的机器上打入就行了

lan0口接外网,lan1口接内网  
最新评论共有位网友发表了评论
发表评论
评论内容:不能超过250字,需审核,请自觉遵守互联网相关政策法规。
用户名: 密码:
匿名评论